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Highlights  

Some of the most important enhancements in GibbsCAM 2026 include the following: 

• GibbsCAM Viewer  

For details, see “GibbsCAM Viewer” on page 6. 

• Improved UI for B-Axis Turning   

For details, see “Variable-B Turning: Improved UI” on page 8. 

• Mill>Contour: Deburr/chamfer of solid part edges  

For details, see “For technical details, such as running Industrial and Viewer on the same 

workstation, PowerOpts, and NLO considerations, see the Installation guide. 
 

• Milling” on page 6. 

• Sim>Settings > Program Time: Option for Sim replay time to match machining time 

For details, see “Visualization and User Interface” on page 10. 

This “Highlights” section is just a small subset of the enhancements in GibbsCAM 2026. The next section 

(“Overview”) provides a complete list. 

Overview of What’s New in GibbsCAM 2026 

The significant enhancement to Milling in GibbsCAM 2026 is: 

• Automated deburring/chamfering of solid part edges 

For details, see “For technical details, such as running Industrial and Viewer on the same workstation, 

PowerOpts, and NLO considerations, see the Installation guide. 
 

Milling” on page 6. 

Important enhancements to Turning include: 

• Variable-B Turning: Improved user interface 

• Collision-avoidance material calculation for multi-sided tools (e.g., CoroTurn Prime) 

• MTM Utility Ops: Extended Move Toolgroup for tool subpositions 
 

For details, see “Turning” on page 8. 
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Enhancements to Visualization and User Interface include: 

• Undo/Redo: Visualization and navigation through Undo/Redo history, listed by action type 

• Drag-and-drop and custom png or jpg image to represent a DCD’s machinetool (MDD) 

• Preference for displaying MDD list sorted alphabetically by name 

• Efficient Shrink Wrap with cylindrical stock 

• Modify>Rotate: New command for nonplanar (out-of-plane) rotations  

• View>Visibility>Measure Measure/analyze/display min|max distance between elements 

• Sim>Settings Update Control: Options for Sim replay proportional to machining time 

• Sim(Op,Mach): Visualization: Optional metallic Rendering appearance 

For details, see “Visualization and User Interface” on page 10. 
 

Improvements to Solids include: 

• Improved engine for Advanced 3D 

• Modify > Scale for solids and sheets 

• Modify > Rotate for nonplanar rotations 

For details, see “Solids” on page 15. 

Improvements to Tooling include: 

• Tool List: Spreadsheet-like list view 

• Tool List: Filter by toolgroup 

• Tool Usage Reporter 

• Support for non-round inserts in VoluTurn 

For details, see “Tooling” on page 18. 
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Miscellaneous improvements and changes include: 

• Updated system requirements (Microsoft desupport of Windows 10) 

• Updated third-party-library support 

• Change to default GibbsCAM paths 

• New/modified plug-ins: 

o Auto CS Create: Option to automatically create CSes from holes, cylinders, and cones 

o New plug-in:  TMiQ for AI-based tool management 

o New plug-in:  ToolsUnited tool library 

o New plug-in:  MachiningCloud tool library 

o Changed workflow and UI for  up2parts autoCAM plug-in 

• Machine Manager: Ability to clone toolgroups 

• Machine Manager Clearance Volume option: Minimize Moves 

• AP242 in menus for File>Import and File>Open 

For details, see “Miscellaneous” on page 22. 
 

5-Axis integrates ModuleWorks 2024.08, 2024.12, and 2025.04, enhancing the following areas: 

• “Calculation based on Multi-blade Machining” ...................................... 24 

• “Calculation based on SWARF Machining” ............................................. 26 

• “Calculation based on Multiaxis Machining” .......................................... 26 

• “Calculation based on Rotary Machining” .............................................. 29 

• “Calculation based on Geodesic Machining” .......................................... 30 

• “Calculation based on Deburring” .......................................................... 31 

• “Tool axis control tab: Tilting” ................................................................ 32 

• “Link” ....................................................................................................... 32 
 

For details, see “5-Axis” starting on page 24. 
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GibbsCAM Viewer 

Customers have long requested a product for reviewing GibbsCAM parts and programming. Such a 

product can allow operators to better understand the parts they will be cutting, can help with shop floor 

communication, and can reduce scrap rates and the amount of effort needed for reports. 

GibbsCAM 2026 provides this new product: GibbsCAM Viewer. Its users have the ability to directly 

access all part information without allowing toolpath generation, posting, or saving/exporting, etc. 

GibbsCAM Viewer and GibbsCAM Industrial share the same installer (product level is determined by 

license) and user interface: Existing GibbsCAM users can use Viewer with no learning curve or training. 

Users of GibbsCAM Viewer can do all the following. 

• Open parts (*.vnc) and packages (*.gcpkg) 

• Rendering, including: 

o Toolpath (including color modes) 

o Wireframe geometry, Solids, Surfaces, and Facet Bodies 

o CS grid, stock, and origin 

o Dimensioning and PMI 

o Show Clearance Planes/Volumes 

o Section View 

o All Simulation modes 

• All View and Viewport controls 

• Measurement: Dimension creation (other than Text), View > Measure, etc. 

• Solid and part query tools and plug-ins: Show Taper Angle/Curvature, Get Draft Angle, Show 

Surface Normals, Solid Inquiry, Show Position, Find Ops, etc. 

• Reporter output 

• Op, Tool, and Process tile lists (including tile list view modes) 

• Op Manager, Tool Manager, and Process Manager (but without Edit capabilities) 

• Op Data dialog 

• Op To Geometry (to permit dimensioning) 

• Utility markers (but not marker placement) 

• Tool and Process dialogs (but with Do It and Redo unavailable) 

• Activate Ops / Deactivate Ops 

• Feature Manager, Attribute Manager, and Hole Manager (with restrictions) 

• CS List / WG List (with restrictions) 

• Program Error Checker 

• Body Bag 

• Printing 

• Update Notification 

• Documentation and Help: PDFs, Online Help, Balloons, Check for Updates, and Copilot 

For technical details, such as running Industrial and Viewer on the same workstation, PowerOpts, and 

NLO considerations, see the Installation guide. 
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Milling 

GibbsCAM 2026 provides an important Milling enhancement. 

Mill Contour: Deburr/Chamfer of solid part edges 
GibbsCAM 2026 adds a new capability to Mill Contour: Automated Deburr/Chamfer. (Requires license 

for 2.5D Solids or SolidSurfacer.) This replaces and supersedes the Deburring plug-in. 

Where to find it: In the Contour dialog box, Contour tab, in pulldown menu, choose 

Deburr/Chamfer. 

What it does: You can now deburr or chamfer edges that you manually select and/or edges of selected 

faces; or you can automatically deburr or chamfer all applicable edges on a selected solid body.  

Note 1: This function operates on solids (it ignores sheets and facet bodies), and thus requires a license 

for 2.5D Solids or SolidSurfacer. 

Note 2: This function expects appropriate tools:  

(a) spherical tips (ball end mills, lollipop mills);  

(b) concave round tips (roundover tools); or  

(c) tools capable of chamfering with a tapered edge (drills, spot drills, and chamfer mills).  

It does not support tools of arbitrary shape or complexity. 

Note 3: When Deburr/Chamfer is active, the Offset tab is not needed and is thus intentionally disabled, 

and inapplicable functions in the Solids tab are suppressed. 

For information on controls specific to Deburr/Chamfer, such as the edge-selection rules used by the 

checkbox Find Internal Edges, see the Mill guide.  
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Turning and MTM 

Version 2026 enhances Turning and MTM in several 

important ways. 

Variable-B Turning: Improved UI 

New features make Variable B turning easier and more 

interactive. 

Where to find it: Turning Contour > Rotate tab > 

Variable B  > (Based On) Interactive. 

What it does: You can now directly control the tool angle at 

arbitrary points along the cut path by specifying control 

points along the path and using Edit and dragging the red line 

(+ or –) to set the tool angle of the tool at those points. The 

angle is automatically interpolated between control points. 

For more information, see the Turning guide. 
 

MTM/Utility Ops: Extended Move Toolgroup for tool subposition 

Previous releases let you park tools using the Move Toolgroup (MTG) utility operation, 

but you could not select tool subposition. If parameters in a Lathe Contour operation’s 

Rotate tab overrode tool subposition, an immediate MTG operation would default to the 

standard subposition, triggering an interop event because of the unintended change in tool subposition. 

GibbsCAM 2026 remedies this with an enhancement to the extended Move Toolgroup utility process. 

In its new Rotate tab, tick the Override Orientation checkbox. 
 

  
Before GC2026 GC2026 MTG utility process dialog: Rotate tab 
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Improved toolpath for multi-sided Turning tools 

In GibbsCAM 2026, toolpath generation is enhanced to provide material calculation to account for multi-

sided Turning tools (MST), such as CoroTurn Prime inserts. 

Before: In previous releases, with nonconvex tools, GibbsCAM was overly cautious in avoiding gouges 

and collisions, placing safety over complete material removal but sometimes leaving unmachined areas: 

Now: GibbsCAM 2026 preserves safety while using more of the insert shape for Prime A and B tools. 
 

 

Toolpath in 
previous releases 

 

Toolpath in 
GibbsCAM 2026 

 

 

Also related to Turning 

• VoluTurn support for non-round inserts .......................................................................  see page 19 
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Visualization and User Interface 
 

View >  Measure minimum/maximum distance 

You can quickly measure minimum and maximum distance between any 

elements in your part, including 2D geometry (point, lines, circles, and splines) 

and the faces and edges of bodies (sheets, solids, and facet bodies).  

Where to find it: On the View menu, under Visibility, click  Measure. 

 

Clicking  Measure opens the Measure dialog box. To specify a pair of elements, you can drag and drop 

markers A and B onto the workspace and then reposition the marker as needed. And/or, you can select 

an element or a group of elements and click Use Selection. The minimum and maximum distances 

between A and B are displayed in the dialog box. 
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1. Pin( ) button 

2. Group A, Group B: 
Each group lists the ID(s) of elements to be measured. 

3. Use Selection —  
Replace current group items with selected element(s). 

4. Reset — Remove all elements from this group.  
To reset both groups: Right-click, then choose Reset. 

5. Minimum — Minimum distance between A and B. 

6. Maximum —Maximum distance between A and B. 

The minimum (yellow) and maximum (pink) distances are also displayed in the workspace as textboxes 

that can be repositioned. To lock the position of a textbox, click its pin button ( ). 
 

Preferences > Appearance Setting > Color|Sim > Metallic Rendering 

You can now specify not just a color but optionally also a metallic appearance for Simulation items. 

Where to find it: On the File menu, click  Preferences; in the Preferences dialog, under Display, click 

Edit Appearance Settings; in the Appearance Settings dialog, click either the Color tab or the Sim tab. 

 
 

Use the Colors tab to assign metallic rendering such items like workpieces, cutting tools/shanks/holders, 

intermediate tooling, fixtures, etc.; use the Sim tab for such items as Target, ActiveOp, Op, Clash, etc.  
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Undo/Redo pulldown menus: Navigate Undo / Redo history 

In the Quick Access toolbar ( , just left of the File/Edit/View main menu), 

the Undo and Redo commands are now pulldown menus. Each pulldown provides 

a list of all the items that can be undone or redone. Dragging the cursor down the 

list provides a count of the number of items that will be undone or redone if a 

selection is made.  

This new function greatly speeds and facilitates navigating to a particular action 

instead of having to pressing Ctrl+Z or Ctrl+Y repeatedly to undo or redo 

many actions.  
 

Sim Replay Proportional to Machining Time 

In the Simulation Settings dialog, a new option under Update Control lets you set the Sim replay to 

approximately match the actual machining time. 

Where to find it: Right-click the titlebar of a Sim Rendering dialog; on the context menu, click Settings. 

In the Simulation Settings dialog, on the Update Control pulldown menu, choose By Program Time. 

 
 

DCD: Custom image for each MDD (machinetool) 

In GibbsCAM 2026, you can assign a custom image for the DCD for each MDD. Simply drag-and-drop an 

image file (*.png or *.jpg) onto the area of DCD, to the right of the machine description parameters and 

to the left of the Open / New / Save / … buttons.  
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Alternatively, you can place an image file named the same as the MDD’s menu inside the MDD\ folder. 
 

Preference option to order MDD list alphabetically (by name) 

You can now order the MDD list by name (or, as in previous releases, by machine complexity). 

Where to find it: File>Preferences dialog, Interface tab, far right: Sort MDD List By.  

 

What it does: The list of MDDs (e.g., DCD > General tab, Machine pulldown) is 

ordered as specified by this Preferences setting.  
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Shrink Wrap with cylindrical stock 

When a part uses cylindrical stock, Shrink Wrap in GibbsCAM 2026 adjusts cylindrical stock to fit tightly 

around the part, instead of fitting the cylinder around the box containing the part.  

Where to find it: On the Modify menu, under Wrap, click Shrink Wrap or Shrink Wrap Visible. 
 

 

 

Before GibbsCAM 2026 GibbsCAM 2026 
 

Also related to visualization and user interface  

• “Variable-B Turning: Improved UI” on page 8 

• “Tool Usage Reporter” on page 18 

• “Tool List: Spreadsheet-like list view” on page 18 
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Solids 
New engine powering  Advanced 3D Machining 

GibbsCAM 2026 introduces a completely re-engineered core for Advanced 3D Machining, now powered 

by the industry-leading ModuleWorks 3-axis engine, delivering improved performance, greater 

robustness, enhanced surface finish, and more efficient toolpaths across a wide range of 3D strategies. 

The user interface remains familiar, but the engine underneath is entirely new — designed to support 

not just today’s needs in an efficient and productive way, but the future of intelligent CAM automation. 

Note: Saving toolpath from Advanced 3D Machining or 5-Axis back to older versions of GibbsCAM is not 

supported. If a part file with Advanced 3D Machining is opened in an older version of GibbsCAM, you 

can view and simulate toolpath and post its NC code, but you cannot re-generate or edit its toolpath. 

While the new engine has no known issues and is fully integrated and production-ready, this is a major 

architectural change. Redo of Advanced 3D operations from previous GibbsCAM releases will often be 

more efficient while preserving the original machining intent, but toolpath generated by the new engine 

may differ slightly or significantly from previous GibbsCAM versions, even with the same parameters. 

Careful testing of Advanced 3D toolpath is required. All Advanced 3D operations should be validated by 

simulation, visual comparison, or other means before being released to production, to ensure the newly 

generated toolpath meets your machining intent. Despite some inconvenience in the short term, this 

change represents the responsible adoption of a next-generation engine. Please treat this as a transition 

to a significantly more advanced solution. Check the Readme file for useful information on Advanced 3D. 

History of SolidSurfacer and Advanced 3D 

• First-generation SolidSurfacer (1996) included toolpath and non-toolpath components. 

• Second-generation SolidSurfacer (2009) included Advanced 3D for the first time, with a then-

modern third-party solution, especially suited for mold and die creation. 

• Third-generation SolidSurfacer (2025) includes “Advanced 3D 2.0” – a full engine replacement 

from ModuleWorks. In GC2026 (phase 1), this new toolpath engine delivers improvements in 

performance, reliability, and surface finish, as well as greater toolpath efficiency. In future, the 

new engine provides an architecture for advanced capabilities and features.  

Why re-engine Advanced 3D? 

• Slow toolpath generation was inadequate for many general manufacturing companies. 

• Results were very sensitive to variations in parameters, making it difficult to use well. 

• Often, multiple iterations were required to obtain a toolpath of good quality. 

• The previous engine went long periods without significant enhancements/fixes/improvements. 

What are the goals of re-engining? 

• Improve performance of toolpath generation 

• Reduce or eliminate the need for multiple iterations. 

• Retain existing user interface as much as possible — minimal retraining for existing users.  

• Equivalent or better surface quality and equivalent or better runtime. 

• Broader tool compatibility. 

• Closer integration with 5-Axis.  
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Minimal changes to the user experience 

The engine is a core-level improvement, and so the user interface for Advanced 3D is mostly unchanged, 

ensuring a familiar experience while improving productivity. You may notice the following: 

• Improvements to reduce confusion:  

o No more Remove spikes, Optimize Z Level, etc.: these are no longer necessary. 

o Hit flats behavior is more consistent. 

o Boundaries are no longer strictly required, and the Boundary Type pulldown has been 

trimmed to remove Shallow Areas and Cutter Contact Areas. Legacy part files that use 

either of these boundary types are converted, issuing a message saying the boundary style 

has been changed to Part Bounding Box. 

o Rest Material is replaced by GibbsCAM-standard “Material Only” functionality. 

o Pocketing and Pocketing With Core Detection strategies are combined. 

• Replaced functionality based on user intent: 

o Adaptive Stepdown is mostly replaced by a more sophisticated Wall Cleanup function. 

o Min/Max Stepover in Pocketing is replaced by constant stepover with corner cleanup. 

o Simplified linking: Has fewer options and yields more efficient results. 

For complete details, see the SolidSurfacer guide, chapter “Advanced 3D”. 
 

Modify > Scale for solids and sheets 

In GibbsCAM 2026, you can scale not just 

geometry, but also solid bodies, facet bodies, and 

sheets. This makes resizing solids and sheets 

simple, easy, and safe within defined limits. 

Where to find it: Under the Modify menu, 

Transform >  Scale (also Duplicate > 

 Dup+Scale). The change is that these 

functions can now be applied to elements 

other than 2D geometry.  

Bodies and sheets can be scaled between 0.02× 

and 50× their original size. (Attempting to scale 

outside this range will trigger a warning and may 

result in invalid geometry.) All scaled bodies and 

sheets retain their original attributes. Scaled 

facet bodies retain the same number of facets. 

This function is particularly useful for fixing import issues caused by unit mismatches (inches vs mm). 

For complete details, see the Common Reference guide, chapter “Main Menu” section “Modify”. 
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 Modify > Rotate for nonplanar rotations  

Where to find it: Under the Modify menu, Transform >  Rotate (also Duplicate >  Dup+Rotate).  

GC2026 adds two new commands under the Modify menu for nonplanar (out-of-plane) rotations, 

reducing the need to create construction CSes. New  Rotate and  Dup+Rotate commands let you 

rotate geometry and features around any axis, not just within the current coordinate system plane.  

This new feature makes it much easier to rotate parts, features, or fixtures that are not aligned to 

standard planes, something that was often difficult or time-consuming in previous releases. 
 

  

 

Before GC2026 GibbsCAM 2026 
 

• Axis of Rotation: You can choose how you want to define the rotation axis. For example, Line 

lets you select a line, hole, or straight edge from geometry or solids. Each method lets you set 

the center point for rotation. Point snapping / selection is supported. 

• Live Preview: A real-time preview of the rotation direction and axis is displayed, allowing you to 

make changes before applying the results. A clear visual (arrow around a bar) appears in the 

workspace. This helps you avoid mistakes with direction or axis choice. 

For complete details, see the Common Reference guide, chapter “Main Menu” section “Modify”. 
 

Also related to Solids 
• Mill > Contour: Deburr/chamfer of edges on 2.5D or solid parts  .................................  see page 6 

• Simulation: Optional metallic rendering appearance  ..................................................  see page 11 

• View > Measure is particularly useful for solids and sheets  ........................................  see page 10 

• Plug-Ins > Auto CS Create offers new options for cylinders and cones  .......................  see page 20 
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Tooling 

Improvements to tools and tooling have occurred throughout GibbsCAM 2026. 

Tool Usage Reporter 

A new manager-type dialog lets you see and manage tools that are currently in use, by operation. 

Where to find it: Double-click a tool tile to open the Tool dialog. Then click  to open the dialog. 

 

Result: The Tool Usage Reporter dialog opens, showing all operations that use the selected tool.  

 

In the dialog, you can … 

• Click a row to select it, or double-click a row to also select the operation and the affected 

workspace elements. 

• Use the upper buttons in the dialog to select/deselect rows. 

• Use the lower buttons to select or delete the associated operation. 
 

Tool List: Spreadsheet-like list view 

You now have the ability to display tool lists in a spreadsheet-like List View with useful column labels. 

Where to find it: Right-click a tool tile and, on the context menu, choose View/Edit Tool List. Navigate 

to a tool list and open it. Then, in the Tool List dialog, click  to display the manager-like list view. 
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Tool List: Filter by toolgroup 

Both views of the Tool List now allow you to filter tools by toolgroups.  

Where to find it: Right-click a tool tile and, on the context menu, choose View/Edit Tool List. Navigate 

to a tool list (*.tlst file) and open it. Then, in the upper right of Tool List dialog, click the pulldown 

menu to change from All TGs to the name of toolgroup whose tools you want to see. 

 
 

VoluTurn support of non-round inserts 

In GibbsCAM 2026, VoluTurn introduces support for non-round inserts. 
 

Also related to Tooling 
• Plug-Ins: TMiQ AI-based tool management system  .....................................................  see page 20 

• Plug-Ins > Tool Libraries: Tool libraries for ToolsUnited and MachiningCloud .............  see page 21 
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Plug-Ins 
The Deburring plug-in is no longer offered, because its functionality has been folded into the Mill 

Contour process; see For technical details, such as running Industrial and Viewer on the same 

workstation, PowerOpts, and NLO considerations, see the Installation guide. 
 

Milling on page 6 or the Mill guide, “Processes” chapter, “Contour” section. 

Plug-Ins > Solids >  Auto CS Create: Enhanced functionality 
 

The Auto CS Create plug-in is now “modeless.” It lets you 
select UI items and workspace elements while the dialog 
remains open. In addition to its previous functionality, you 
can now instruct the system to automatically create CSes at 
the tops of the axes-of-rotation of cylinders/cones, including 
holes. A checkbox lets you specify whether to create only 
one CS for cylinders/cones/holes that share the same axis. 

Where to find it: Plug-Ins >Solids>  Auto CS Create 

 

 

 

 
Before GibbsCAM 2026 GibbsCAM 2026 

 

 New Plug-In: TMiQ 

ToolManageriQ (TMiQ), developed by CAM Solutions, is an 

AI-based tool management system for organizing cutting 

tools, holders, assemblies, fixtures, and suppliers, accessed 

via the Plug-Ins menu. A standalone version is also available. 

• Initially, TMiQ is not installed, and Plug-Ins > Tool 

Managers > TMiQ plays an embedded video. In the right lower corner of 

the video is a green INSTALL NOW button that lets you install a fully 

functional version of ToolManageriQ for 30 days. When the free 30-day 

trial expires, you will be prompted to purchase a license through the 

dedicated TMiQ site. 

• After ToolManageriQ has been installed as an integrated 

GibbsCAM plug-in, you can access its functionality via 

Plug-Ins > Tool Managers > TMiQ: 

• For installers and documentation, visit this website: https://toolmanageriq.com/downloads 

• For video tutorials, visit this website: https://www.youtube.com/@toolmanageriq1062/videos 

https://camsolutions.ca/products/toolmanageriq/
https://toolmanageriq.com/downloads
https://www.youtube.com/@toolmanageriq1062/videos
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Tier 1 support for TMiQ is provided by the GibbsCAM team. Advanced or in-depth support is handled 

directly by CAM Solutions. 
 

 

 New Plug-In Tool Libraries:  ToolsUnited,  MachiningCloud  

GibbsCAM 2026 supplies two new third-party tool library importers: ToolsUnited and MachiningCloud, 

similar in workflow to CPTL (CoroPlus Tool Library), accessed via the Plug-Ins menu. 
 

 

 Plug-Ins > Main Tools >  up2parts autoCAM 

The GibbsCAM  up2parts autoCAM plug-in is now directly connected to the up2parts cloud after login 

credentials are supplied. Instead of transferring a *.zip file, you now select the desired CAM project in 

the redesigned user interface and open it directly in GibbsCAM. A new up2parts autoCAM feature is 

support for Through Pockets, including operations for Level Roughing and Wall Finishing. 
 

 This symbol indicates that an internet connection is required. 
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Miscellaneous 

Microsoft desupport of Windows 10 

Microsoft has officially announced that Windows 10 will reach end-of-support in October 2025. In line 

with this, GibbsCAM 2026 will not support Windows 10. 

What does this mean for you? 

Microsoft will stop providing technical support for Windows 10 and will stop updates, such as: 

• Security patches to protect against viruses and malware 

• Bug fixes and improvements 

• Compatibility updates for new hardware and software 

Windows 11 has been stable and widely adopted since its release in 2021, and we are fully aligned with 

it going forward. If you are on Windows 10, upgrade to Windows 11 to ensure: 

• Full compatibility with GibbsCAM 2026 and later GibbsCAM versions 

• Better performance and reliability 

• Enhanced security and ongoing updates from Microsoft 
 

Change to default GibbsCAM paths 

In GibbsCAM 2026, unlike previous releases, default installation and data paths are now: 

• Installation: C:\Program Files\Gibbs\GibbsCAM\<release>_<locale>\ 

• Global data (All Users): C:\ProgramData\Gibbs\GibbsCAM\<release>\ 

• User data: C:\Users\<username>\AppData\Roaming\Gibbs\GibbsCAM\<release>\ 

The transition is seamless for most users, because the change is fully supported by the GibbsCAM 

Migration Tool. However, sites that do not use the Migration Tool and people who manually access 

folders for copying or referencing files should know to change (from ~\CAMBRIO\GibbsCAM\~) to 

~\Gibbs\GibbsCAM\~. 
 

System requirements 

OS: ................... Windows 11 or Windows Server 2022. 

CPU: ................. Intel Core i9, i7, or i5 with four or more cores; or 

AMD Ryzen or Threadripper  

RAM: ................ 16+ GB 

Video card: ....... NVIDIA video card with 4+ GB of video memory 
 

Third-party library support 

• ModuleWorks 2024.08, 2024.12, and 2025.04 

• VoluMill 10.5; VoluTurn 10  

• Parasolid 37, ACIS 2025.1, SolidWorks 2025, Solid Edge 2025, Catia v5 R2025, Inventor 2026, 

etc.; see the Data Exchange guide for the complete list 
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Machine Manager: Ability to clone toolgroups 

Machine Manager now allows you to clone a toolgroup ( ) node with all child 

nodes it may contain. 

Where to find it: In Machine Manager, right-click a toolgroup node and, on the 

context menu, choose Clone. 
 

Machine Manager: Clearance Volumes > Minimize Moves 

To minimize tool retracts, Clearance Volumes can be defined in the MDD — see illustration — causing 

the Clearance (Δ) field to appear in the DCD’s Workspace tab.  

In GibbsCAM 2026, Machine Manager’s Set Clearance Behavior dialog now provides a Minimize Moves 

checkbox that further increases efficiency between operations where the tool does not rotate to a new 

orientation, and where the tool is aligned with a linear axis.  
 

 

AP242 in pulldown menus for File>Import and File>Open 

The File>Import and File>Open dialogs now list AP242 along 

with other STEP (Spatial) *.stp/*.step data types. 

Where to find it: In the File>Open or File>Import dialogs, click 

the pulldown menu in the lower right (just above the Open 

button). 
 

For same-tool interops that stay on the part, when 

Minimize Moves is in effect, the tool retracts to the 
highest position needed to prevent its traversal from 
intersecting the clearance volume as the tool rotates 
and moves above the start point of the next operation.  

Where to find it: In Machine Manager, Machining Prefs 
tab, under Clearance Behavior: In the pulldown, 
choose Clearance Volumes. Then, click the Volumes 
button to open the Set Clearance Behavior dialog, 
which now offers a Minimize Moves checkbox.  
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5-Axis 

Doc Note: As of the start of Open Beta, this chapter of What’s New is still under construction. It might 

contain errors, duplications, or omissions.  
 

This chapter discusses the following enhancements to 5-Axis in GibbsCAM 2026. 

• “Calculation based on Multi-blade Machining” ...................................... 24 

• “Calculation based on SWARF Machining” ............................................. 26 

• “Calculation based on Multiaxis Machining” .......................................... 26 

• “Calculation based on Multi-blade Machining” ...................................... 24 

• “Calculation based on Rotary Machining” .............................................. 29 

• “Calculation based on Geodesic Machining” .......................................... 30 

• “Calculation based on Deburring” .......................................................... 31 

• “Tool axis control tab: Tilting” ................................................................ 32 

• “Link” ....................................................................................................... 32 
 

Calculation based on Multi-blade Machining 

~\WN_MW2025.04\sources\1543735070.html Toolpath: Special Parts > Multiblade 

Multiblade Edge Finishing 

Where to find it: (Multi-blade machining) Surface paths tab > Machining > Edge Finishing 

This new edge finishing strategy guides the tool longitudinally along the edge to remove any excess 

material left from the previous operation without causing damage to the thin leading edge. This allows 

the part to be finished with the required surface quality and material integrity. It ensures that the thin 

leading edge is not damaged, maintaining the integrity and quality of the finished part.  
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~\WN_MW2024.12\sources\1477050564.html Toolpath: Special Parts > Multiblade 

Feedrate for Links in Multiblade 

Where to find it: (Multi-blade machining) Link tab > Link Feedrate (%) 

Previously, it was difficult to optimize the non-cutting time because it was not possible to adjust the 

feedrate on the links. But it is often desirable during a non-cutting move to increase the feedrate to 

reduce machining time. With this release, you now have the ability to customize the feedrate for links. 

This gives you greater control over the machining process while reducing the overall cycle time. 

 
 

Feedrate Override for Leads in Multi-blade 

This feature allows lets you set the feedrate override for leads. 

Where to find it: (Multi-blade machining) Link tab > Lead-in Feedrate(%) / Lead-out Feedrate(%) 

In previous releases, you were limited to using feedrate overrides only for links, extensions, and the 

actual toolpath. Now, there is an option to set the feedrate override for lead-in and lead-out moves as a 

percentage of the actual toolpath feedrate. This feature ensures the tool enters and exits the workpiece 

smoothly, resulting in a better surface finish and improved tool life.  

 
 



What’s New in GibbsCAM 2026 (Beta)  

WN2026_Draft08.docx     Page 27 of 34   Last modified: 2025-09-08 at 08:20 

~\WN_MW2024.08\sources\1385529588.html Toolpath: Special Parts > Multiblade 

Expanded tool support for Blade Finishing 

Where to find it: Surface paths tab > Machining/blade finishing > Leading/Trailing edge > Feedrate(%) 

In previous releases, Multiblade Finishing required ball end mills for machining impellers and blisks. 

This prevented the use of standard tools such as flat end mills and bullnose mills.  

Now, you can use bullnose mills, end mills, and all types of taper tools for blade finishing. This provides 

more machining flexibility to use standard tools such as bullnose mills for multiblade finishing.  

Control Feedrate on Edge Extension 

You can now control the feedrate for leading and trailing edge extensions. 

Where to find it: (Multi-blade machining) Tool tab > Tool type 

When applying extensions to the leading or trailing edge, the aim is to leave offset material to finish 

later. Therefore, since the extension is not going to actively cut the material, it makes sense to increase 

the feedrate to save machining time. The Feedrate(%) parameter, which previously modified only the 

feed when the tool touches the blade, has been expanded and now also applies to the extensions. It is 

now possible to use a faster feedrate for leading and trailing edge extensions, reducing the overall 

machining cycle time. 
 

Calculation based on SWARF Machining 

~\WN_MW2024.12\sources\1481670953.html Toolpath: Multi-Axis Surface Finishing > SWARF Machining 

The 4-axis SWARF mode has been enhanced to achieve optimal geometric accuracy. The surfaces of 

some parts, such as cylindrical cams, can be geometrically machined using flank milling on a relatively 

inexpensive 4-axis machine. However, when machining with a tool smaller than the slot, it is difficult to 

optimally align the tool with the surfaces. 

This enhancement improves the accuracy of parts, reduces machining costs, and offers greater flexibility 

in selecting tool diameters. 
 

Calculation based on Multiaxis Machining 

~\WN_MW2024.08\sources\1394770483.html Toolpath: Area Roughing 

Detect Material Thicker Than 

Where to find it: (Multiaxis machining) Surface Paths page > Area > Detect thicker than 

With this feature, thickness of rest material gets detected considering the preset value. This improves 

the quality of stock-based roughing operations, as the tool does not go into the unnecessary areas.  
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~\WN_MW2024.12\sources\1447952990.html Toolpath: Multi-Axis Surface Finishing > Wall/Floor/Rest Finishing 

Advanced Barrel Tool Support for Multi-Axis Surface Finishing 

Advanced barrel mills allow you to precisely define the geometry of barrel tools. 
 

~\WN_MW2024.08\sources\1398341663.html Toolpath: Multi-Axis Surface Finishing 

For Machining choices Wall Finishing, Floor Finishing, and Rest Finishing, under Area: New controls 

for Extend Toolpaths; and (for Wall Finishing) new Parallel to floor pattern. 

Toolpath Extensions: This feature allows the tool to extend its motion beyond the 

start and end point of each closed contour. This reduces the size of the cusps at 

the start and end points, particularly with advanced tools such as barrel tools, and 

produces clean surfaces. 

Parallel to floor pattern: The new Parallel to floor surface cut pattern for wall 

finishing generates slices parallel to a planar floor to ensure that features on the wall do not disrupt the 

pattern generation. This introduces a whole new set of geometries that can be machined with less tilting 

and better surface quality. 
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~\WN_MW2024.12\sources\1477051587.html Toolpath: Multi-Axis Roughing > Area Roughing 

Primitives Definition as Clearance Area 

Where to find it: Link tab > Clearance area > Clearance area dialog 

You can now define the clearance area as Plane, Sphere, Cylinder, or Surface to better handle retracts. 

• Plane: The planar area is raised above the workpiece at the specified height and in the desired 

direction. The direction is determined by the direction of the plane normal vector. 

• Cylinder: The cylindrical area around the workpiece is specified by the radius and desired 

direction. This can be useful for 4-axis and 5-axis machining operations. 

• Sphere: The spherical area around the workpiece with a specified radius and desired position. 

The position can be defined as XYZ coordinates or by an imported point.  
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Calculation based on Rotary Machining 

~\WN_MW2025.04\sources\1560740134.html Toolpath: Multi-Axis Surface Finishing > Rotary Machining Finishing 

Cone Angle Normal to Conical Surface 

Where to find it: (Rotary Machining > Finishing) Surface paths tab, under Tool orientation  

With this enhancement, it is now possible to define the angle for floor detection while keeping the 

milling head stationary or tilting it to a completely different angle. This enables more versatile and 

efficient machining of angled floors. The system detects and applies toolpath on conical floors without 

tilting the milling head, providing greater flexibility and precision during rotary finishing. 

 
 

~\WN_MW2024.12\sources\1447953226.html Toolpath: Multi-Axis Surface Finishing > Rotary Machining Finishing 

Support for Fixtures/Chucks for Rotary Machining Finishing 

Where to find it: Part definition tab > Machining surfaces > Fixture  

Fixtures and chucks can now be selected as a mesh/model. The mesh/model is then spun and the 

resulting profile is used to avoid collisions.  

With this enhancement, you can select Fixtures/chucks that will now be included in the collision 

avoidance calculations for Rotary Roughing toolpaths. 

You can now select fixtures/chucks for inclusion in the collision avoidance calculations for rotary 

finishing toolpaths. The selected mesh/model is spun and the resulting profile is used to avoid collisions. 

You can specify an offset distance to provide more control and safety, resulting in more confidence 

during toolpath generation. This also simplifies the implementation for CAM partners. 

Leads for Floor Finishing 

Where to find it: Part definition > Link tab > Contour Leads           
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You can now define lead-in/lead-out for the finishing pattern for rotary machining of cylindrical or 

conical surfaces. This ensures smooth entry into the material and fewer tool marks, improving the 

surface finish in some cases. 

~\WN_MW2024.12\sources\1447953162.html Toolpath: Multi-Axis Roughing > Rotary Machining Roughing 

Support for Fixtures/Chucks for Rotary Machining Roughing 

Where to find it: Part definition tab > Machining surfaces > Fixture 

You can select fixtures and chucks to include them in collision-avoidance calculations for rotary roughing 

toolpaths. (The selection is treated as a mesh/model that is spun, and the resulting profile is used to 

avoid collisions.) An offset distance is also provided to give users more control and safety.  

Support for fixtures/chucks provides more safety and confidence to the user during toolpath generation. 

This also simplifies implementation for CAM partners. 

~\WN_MW2024.08\sources\1381171832.html Toolpath: Rotary Machining Finishing 

Containment Trim for Rotary Finishing 

Where to find it: Part definition tab > Containment > Trim 

This feature trims the toolpath as the tool center touches the containment region. This helps to avoid 

unnecessary extensions of toolpath beyond the containment. 

The containment is designed to have a toolpath up to its boundaries to ensure that material is removed. 

However, when finishing, you can add the boundary without adding a toolpath. This lets you tailor the 

toolpath and benefit from the containment function. 
 

Calculation based on Geodesic Machining 

~\WN_MW2024.12\sources\1480196382.html Toolpath: Multi-Axis Surface Finishing > Geodesic Machining 

Multiple Boundary Passes  

Where to find it: (Geodesic) Surface paths tab > Containment > Advanced > Cut along containment 

This feature lets you set up a machining operation for the boundary of an area. A new operation is 

created that  allows full customization of the boundary pass. For example, a different stepover or tilting 

behavior can be used for the boundary pass. This results in improved surface quality and safer 

operations. 
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~\WN_MW2024.08\sources\1356988591.html Toolpath: Multi-Axis Surface Finishing > Geodesic Machining 

Robustness against Input Deviation 

With this enhancement, small changes to the mesh (new triangulation, different mesh offset or different 

mesh patching) now have a smaller effect on the toolpath. 
 

Calculation based on Deburring 

~\WN_MW2025.04\sources\1556545976.html Portfolio=Toolpath > Multi-Axis Edge Finishing > Deburring 

Automatic Machining Direction 

Where to find it: (Deburring) Surface paths tab > Path parameter > Direction 

In previous releases, determining the appropriate machining direction for a 3- and 4-axis toolpath often 

led to suboptimal ordering. Now, you can use Automatic Machining Direction to determine the 

machining direction automatically based on the contour definition. This makes toolpath deburring more 

user-friendly, while also reducing the machining cycle time. 

User-Defined Edge Sequence 

Where to find it: (Deburring) Surface paths tab > Geometry input 

With automatic sorting, it is difficult to meet the deburring requirements of each part, because the 

predefined order may not align with specific needs.  

This feature provides an alternative to automatic sorting: The input order of the included curves can be 

preserved and the resulting toolpath is sorted accordingly, but you can select edges for machining in 

whatever sequence you prefer, providing greater flexibility during the deburring process and improving 

overall efficiency and precision.  
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~\WN_MW2024.12\sources\1396081627.html Toolpath: Multi-Axis Edge Finishing > Deburring 

Consolidated 3+2 Behavior 

The common direction algorithm has been enhanced for deburring to ensure a 3+2 orientation with 

minimal 5-axis movements. This minimizes undesired 5-axis motions, resulting in safer and more 

accurate machining. 
 

Tool axis control tab: Tilting 

~\WN_MW2024.08\sources\1409351785.html Toolpath: Tilting Core 

Autotilt Support for Bullnose Tools 

This enhancement enables the autotilt option to be used with bullnose tools. 

Tilted into plane 

A new tilting strategy,, Tilted into plane, lets you tilt the tool axis in the plane defined by the normal to 

a direction you select. The tool axis is projected on the selected plane on each toolpath point. 

If the plane normal is aligned with a rotational axis of the machine, it limits rotational machine 

movements to that axis.  

Tilt Tool in a User Defined Plane 

A new tilt option, Tilt tool in a user defined plane, has been introduced to eliminate one Degree of 

Freedom (DOF). This feature lets you restrict the tool axis in a plane that you define. Depending on the 

orientation of this plane, either rotary or tilt can be avoided completely. If the plane normal is aligned 

with a rotational axis of the machine, it will limit rotational machine movements to that axis. 

Benefits: You can expect fewer machine axis movements for more stable machining. 

Automatic Tilting Kernel for Existing Toolpath 

The new automatic tilting kernel for existing toolpaths provides more consistent results and acts as an 

enabler for using the latest features. 
 

Link Tab: Linking 

~\WN_MW2024.12\sources\1447952990.html Toolpath: Linking 

Tool Axis Clearance Control 

Instead of retracting normal to the clearance, this release now allows the option to retract or approach 

along the tool axis until it connects with the clearance. 
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Automatic Clearance Improvement 

This enhancement optimizes links for cylindrical or spherical surfaces, reducing machining time while 

maintaining necessary clearance during linking motion. It applies specifically when the clearance area 

type is set to automatic, or when the user selects a cylinder/sphere clearance area type with position 

and radius options set to automatic. 

User Defined Clearance Areas 

Where to find it: Link tab > Retracts dialog 

This new feature lets you select user-defined surfaces as clearance areas. With this feature, toolpaths 

can be limited to shorter retracts, thereby reducing the overall cycle time while providing more 

flexibility and control to the user. 

Virtual Fixture Plane for Safe Linking 

Where to find it: Link tab > Retracts dialog 

With this feature, you can avoid links that go beyond the defined virtual fixture plane. This prevents the 

tool from entering dangerous areas: The fixture plane is defined according to a user-specified height so 

that links are forced to stay above that plane. Defining the fixture plane reduces the risk of collisions, 

even on complex machining setups. 

Note: The Virtual Fixture Plane option is available for Sphere Clearance only. 
 


